A fix has been implemented and we are monitoring the results.
Posted May 20, 2025 - 18:06 AEST
Identified
The issue has been identified and a fix is being implemented.
Posted May 20, 2025 - 18:05 AEST
Investigating
Secure Office Documents are currently experiencing issues and we are working to identify and resolve the issue. We will provide an update here in 15 minutes.
Posted May 20, 2025 - 17:44 AEST
This incident affected: Ansarada Data Room (Documents).